Gentoo и e2fsprogs-1.41.2

Дождались новых  ebuild’ов. Но тут возникла проблемка с e2fsprogs и e2fsprogs-libs — они не захотели сразу обновляться, их заблокировали.

[blocks B     ] sys-libs/com_err («sys-libs/com_err» is blocking sys-libs/e2fsprogs-libs-1.41.2)
[blocks B     ] sys-libs/e2fsprogs-libs («sys-libs/e2fsprogs-libs» is blocking sys-libs/com_err-1.40.9, sys-libs/ss-1.40.9)
[blocks B     ] sys-libs/ss («sys-libs/ss» is blocking sys-libs/e2fsprogs-libs-1.41.2)

Попробовал удалить данные библиотеки и сразу отвалился wget.
Вот тут то меня и осенило:

USE="-ssl" emerge wget
emerge --unmerge ss com_err

И система обновилась без проблем.
А вообще нужно почитать поподробнее об этом баге.

Реклама

комментариев 5 to “Gentoo и e2fsprogs-1.41.2”

  1. Ко Says:

    Ну так что почитал подробнее об этом баге?
    Что делать то надо?
    И как ты эти библиотеки удалил? (rm что ли?)

  2. wildarcher7 Says:

    1) USE=»-ssl» emerge wget
    2) emerge —unmerge ss com_err
    3) emerge —update —deep —newuse world
    4 ) пока так решил проблему.

  3. Ко Says:

    Спаибо! Сделал так же — все нормально обновилось!

  4. gals Says:

    IMHO дело было не в опциях сборки wget, openssl и ss вобще никак не связаны, и заголовок поправить надо бы, дождались новых размаскированных ебилдов 🙂 а то те у кого keyword уже давно сидят на sys-libs/e2fsprogs-libs

  5. sergei Says:

    Spasibo


Добавить комментарий

Заполните поля или щелкните по значку, чтобы оставить свой комментарий:

Логотип WordPress.com

Для комментария используется ваша учётная запись WordPress.com. Выход / Изменить )

Фотография Twitter

Для комментария используется ваша учётная запись Twitter. Выход / Изменить )

Фотография Facebook

Для комментария используется ваша учётная запись Facebook. Выход / Изменить )

Google+ photo

Для комментария используется ваша учётная запись Google+. Выход / Изменить )

Connecting to %s

%d такие блоггеры, как: