linux-headers-2.6.28 и gentoo

Вот решил отважится на ACCEPT_KEYWORDS=»~x86″. Обновил все пакетики и запустил emerge -e system. Процесс сорвался на kbd-1.5.0. примерно с таким вот сообщением:

error: expected specifier-qualifier-list
before ‘__u32’

Рещение проблемы:
echo «=sys-kernel/linux-headers-2.6.28» >> /etc/portage/package.mask
emerge linux-headers glibc
emerge kbd

С linux-headers-2.6.27-r2 никаких проблем со сборкой kbd не было.

Опубликовано в Gentoo. Метки: , . 5 комментариев »